Product and Support Advisory

Following is important information regarding your HyperGrid products and services.

Please review to take advantage of our latest product enhancements and bug fixes.

Please contact HyperGrid Technical Support to create a customized upgrade plan, if your HyperGrid product version is below 3.8.1.

Please check out the latest HyperGrid offerings here or email us at [email protected].

We are deeply committed to partner with you to provide any assistance needed as you consider an upgrade to our latest product versions.

*If your node is running Windows 2008, please contact HyperGrid Support

**Customers who are on 3.5 or below, please contact HyperGrid Support

***Existing active support contracts beyond End of support date will be honored through contract end date

Contact Technical Support